Re: No handlers could be found for logger "mongo_connector.util"

From: Luke Lovett <luke.lovett@xxxxxxxxx>
To: mongodb-user <mongodb-user@xxxxxxxxxxxxxxxx>
Date: Thu, 14 Apr 2016 09:58:30 -0700 (PDT)
Why ads?
The problem lies in the neo4j_doc_manager: 
https://github.com/neo4j-contrib/neo4j_doc_manager. It appears that it ;
requires Python >= 2.7 to use. The README recommends Python 3: 
https://github.com/neo4j-contrib/neo4j_doc_manager#installing

On Thursday, April 14, 2016 at 1:29:25 AM UTC-7, Flavio Oliveira wrote:

Hi,

I always got the error below when I try to run mongo-connector with neo4j 
doc manager. I also tried with a config file as in 
https://github.com/mongodb-labs/mongo-connector/blob/master/config.json

Where is the problem?

mongo-connector -m localhost:27017 -t http://localhost:7474/db/data -d ;
neo4j_doc_manager
No handlers could be found for logger "mongo_connector.util"

Traceback (most recent call last):
  File "/usr/bin/mongo-connector", line 11, in <module>
    sys.exit(main())
  File "/usr/lib/python2.6/site-packages/mongo_connector/util.py", line 
85, in wrapped
    func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/mongo_connector/connector.py", 
line 1041, in main
    conf.parse_args()
  File "/usr/lib/python2.6/site-packages/mongo_connector/config.py", line 
118, in parse_args
    option, dict((k, values.get(k)) for k in option.cli_names))
  File "/usr/lib/python2.6/site-packages/mongo_connector/connector.py", 
line 824, in apply_doc_managers
    module = import_dm_by_name(dm['docManager'])
  File "/usr/lib/python2.6/site-packages/mongo_connector/connector.py", 
line 803, in import_dm_by_name
    module = __import__(full_name, fromlist=(name,))
  File 
"/usr/lib/python2.6/site-packages/mongo_connector/doc_managers/neo4j_doc_manager.py", 
line 16, in <module>
    from py2neo import Graph, authenticate
  File "/usr/lib/python2.6/site-packages/py2neo/__init__.py", line 28, in 
<module>
    from py2neo.database import *
  File "/usr/lib/python2.6/site-packages/py2neo/database/__init__.py", 
line 65
    parameters = {k: v for k, v in parameters.items() if k not in 
presub_parameters}
                         ^
SyntaxError: invalid syntax


Regards, Flavio


-- 
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.org/manual/support/
--- 
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+unsubscribe@xxxxxxxxxxxxxxxx.
To post to this group, send email to mongodb-user@xxxxxxxxxxxxxxxx.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/56b44519-1bfd-42b9-a0fa-77b5182d9505%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Why ads?