Installing MongoDB Enterprise 3.2 on Redhat Linux 7

From: Jeffrey Schade <jschade100@xxxxxxxxx>
To: mongodb-user <mongodb-user@xxxxxxxxxxxxxxxx>
Date: Thu, 21 Apr 2016 10:11:42 -0700 (PDT)
Why ads?
I am getting error about missing packages when I try to install MongoDB 
(See red). I tried doing command sudo yum install openssl net-snmp 
net-snmp-libs cyrus-sasl-lib cyrus-sasl-gssapi krb5-libs to install the 
missing packages and it says No package cyrus-sasl-gssapi available. I am 
stuck and would appreciate any assistance as I am new to MongoDB

 

root@0931-PCRMGD-U01 yum.repos.d]# sudo yum install -y mongodb-enterprise

Loaded plugins: product-id, search-disabled-repos, subscription-manager

This system is registered to Red Hat Subscription Management, but is not 
receiving updates. You can use subscription-manager to assign subscriptions.

mongodb-enterprise                                                                                                                                                            
| 2.5 kB  00:00:00

mongodb-enterprise/7Server/x86_64/primary_db                                                                                                                                  
|  34 kB  00:00:00

Resolving Dependencies

--> Running transaction check

---> Package mongodb-enterprise.x86_64 0:3.2.5-1.el7 will be installed

--> Processing Dependency: mongodb-enterprise-tools = 3.2.5 for package: 
mongodb-enterprise-3.2.5-1.el7.x86_64

--> Processing Dependency: mongodb-enterprise-shell = 3.2.5 for package: 
mongodb-enterprise-3.2.5-1.el7.x86_64

--> Processing Dependency: mongodb-enterprise-server = 3.2.5 for package: 
mongodb-enterprise-3.2.5-1.el7.x86_64

--> Processing Dependency: mongodb-enterprise-mongos = 3.2.5 for package: 
mongodb-enterprise-3.2.5-1.el7.x86_64

--> Running transaction check

---> Package mongodb-enterprise-mongos.x86_64 0:3.2.5-1.el7 will be 
installed

---> Package mongodb-enterprise-server.x86_64 0:3.2.5-1.el7 will be 
installed

--> Processing Dependency: cyrus-sasl-plain for package: 
mongodb-enterprise-server-3.2.5-1.el7.x86_64

--> Processing Dependency: cyrus-sasl-gssapi for package: 
mongodb-enterprise-server-3.2.5-1.el7.x86_64

--> Processing Dependency: cyrus-sasl for package: 
mongodb-enterprise-server-3.2.5-1.el7.x86_64

---> Package mongodb-enterprise-shell.x86_64 0:3.2.5-1.el7 will be installed

--> Processing Dependency: cyrus-sasl-plain for package: 
mongodb-enterprise-shell-3.2.5-1.el7.x86_64

--> Processing Dependency: cyrus-sasl-gssapi for package: 
mongodb-enterprise-shell-3.2.5-1.el7.x86_64

--> Processing Dependency: cyrus-sasl for package: 
mongodb-enterprise-shell-3.2.5-1.el7.x86_64

---> Package mongodb-enterprise-tools.x86_64 0:3.2.5-1.el7 will be installed

--> Processing Dependency: cyrus-sasl-plain for package: 
mongodb-enterprise-tools-3.2.5-1.el7.x86_64

--> Processing Dependency: cyrus-sasl-gssapi for package: 
mongodb-enterprise-tools-3.2.5-1.el7.x86_64

--> Processing Dependency: cyrus-sasl for package: 
mongodb-enterprise-tools-3.2.5-1.el7.x86_64

--> Finished Dependency Resolution

*Error: Package: mongodb-enterprise-tools-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl-gssapi*

*Error: Package: mongodb-enterprise-tools-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl-plain*

*Error: Package: mongodb-enterprise-shell-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl-plain*

*Error: Package: mongodb-enterprise-server-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl-gssapi*

*Error: Package: mongodb-enterprise-server-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl*

*Error: Package: mongodb-enterprise-server-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl-plain*

*Error: Package: mongodb-enterprise-tools-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl*

*Error: Package: mongodb-enterprise-shell-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl*

*Error: Package: mongodb-enterprise-shell-3.2.5-1.el7.x86_64 
(mongodb-enterprise)*

*           Requires: cyrus-sasl-gssapi*

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

[root@0931-PCRMGD-U01 yum.repos.d]#


Thanks 

Jeffrey Schade




-- 
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.org/manual/support/
--- 
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+unsubscribe@xxxxxxxxxxxxxxxx.
To post to this group, send email to mongodb-user@xxxxxxxxxxxxxxxx.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/93c16b33-77e8-4b3e-8134-3088322107d3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Why ads?